HipChat in Artful 17.10 not working

Since updating Ubuntu from 17.04 Zesty to 17.10 Artful HipChat has stopped working. If you click the icon it appears in the bar, and you get a big white window – suggesting this is as much down to the way in which it is displaying as much as anything else. Running it from the console spews endless errors to the screen and you get the same outcome. Winning.

Having become fed up with people asking if I had fixed it yet, or why I hadn’t¬†read their message (buried in a VM on another desktop with no alerting natively) – it became a priority to find a fix. So here we are – edit the following file:

sudo vim /opt/HipChat4/bin/QtWebEngineProcess

…and then update it with this goodness:

arguments=”$@ –disable-seccomp-filter-sandbox”

So to be clear.

#!/bin/bash
commandtorun=''
arguments=$@
if [[ "$1" = "--gdb" ]]
then commandtorun="gdb"
arguments=''
echo running command
fi;
if [[ "$1" = "--ldd" ]]
then commandtorun="ldd"
arguments=''
echo running command
fi;
if [[ "$1" = "--callgrind" ]]
then commandtorun="valgrind --tool=callgrind"
arguments=''
echo running command
fi;
if [[ "$1" = "--valgrind" ]]
then commandtorun="valgrind --error-limit=no"
arguments=''
echo running command
fi;
if [[ "$1" = "--qmldebug" ]]
then arguments="$@ -qmljsdebugger=port:60111,block"
fi;
echo $1

…is how that was looking. Now it is looking a lot more like this…

#!/bin/bash
commandtorun=''
#arguments=$@
arguments="$@ --disable-seccomp-filter-sandbox"
#if [[ "$1" = "--gdb" ]]
# then commandtorun="gdb"
# arguments=''
# echo running command
#fi;
#
#if [[ "$1" = "--ldd" ]]
# then commandtorun="ldd"
# arguments=''
# echo running command
#fi;
#
#if [[ "$1" = "--callgrind" ]]
# then commandtorun="valgrind --tool=callgrind"
# arguments=''
# echo running command
#fi;
#
#if [[ "$1" = "--valgrind" ]]
# then commandtorun="valgrind --error-limit=no"
# arguments=''
# echo running command
#fi;
#
#if [[ "$1" = "--qmldebug" ]]
# then arguments="$@ -qmljsdebugger=port:60111,block"
#fi;
#
echo $1

Amazing. it works. Happy days. No more finding the right virtual desktop, finding te VM running in it, finding the App, opening it, finding all the messages you have missed and why people are looking at you confused / annoyed.

HAPPY DAYS.

The original work around was posted here: https://jira.atlassian.com/browse/HCPUB-3559

 

One Response to “HipChat in Artful 17.10 not working

  • I have just had an update to this I am guessing as this has reverted.

    Make the changes again I will.

    Returns to working it does.

Leave a Reply

Your email address will not be published. Required fields are marked *

%d bloggers like this:
Skip to toolbar