No f*cking Java

Once upon a time there was the wonder, the hope, the dream of the one programming language to bind them all – you could run the same code on your toaster maybe than you could on your desktop. Suitable awe was dispatched.

That in an era when the Z80 was in just about everything from photocopiers to televisions … and no one saw the reality ahead that you would, before too long, have a linux box running everything from your home router to your desktop to your phone. A common C based architecture with mostly an open code base. Oh the aching majesty of it all.

So here we are – 2017 – living in the future… and Java is still a thing. Sure there are Java certified programmers out there that would probably disagree with me … but in a world that has embraced the wonder that is HTML5, and where other tools exist such as VNC… why oh why oh why do we still find ourselves in a world where I cannot use a given KVM because my version of Java is too new.

…or where I need to have Java installed, when there are sites that lampoon the days since it’s last serious security flaw.

This rant was bought to you by the number of likes I got for a passing comment having overheard a conversation and watched some google for:

KVM with no f*cking Java

Because lets be clear here – the chances are – if you are needing to access a KVM – the world is not full of fluffy bunnies, chocolates, and wine. No.

Java – specifically in these application spaces – your time has come…. you… and Nagios son of NetSaint … it’s time to let go and slip silently into the void to live on only reminiscence of elderly engineers over a coffee or beer.

So – now just need to decide on a solution…

One Response to “No f*cking Java

  • [update on this Monday 27th March 2017]

    Having moved from now EoL CentOS5 to the recommended release for our Xen based virtualisation platform – I cannot really even begin to share the deep, DEEP JOY, that is clicking on console and it happening in HTML5 as opposed to Java.

    No more clawing at the screen as you notice your package update is changing your Java version. Gone are the “is the right browser” “right java” “right java version” – nnnnrrrrgggh! NooooooooOOOOOOOOOO! … and then asking around for everyone else to have a go at getting logged in. GREAT SUCCESS.

Leave a Reply

Your email address will not be published. Required fields are marked *

%d bloggers like this:
Skip to toolbar