R1soft support kernel 3.19 to 4.0

There isn’t any.

SURPRISE!

I ran custom compiled kernel modules for 3.19.0-15 and 3.15.0-18 and found that I was seeing a lot of errors regarding IO issues.

As it transpires, this was not just with respect the CDP agent – this was also true of the wider access to storage.

Looking at the following you can see when I installed the kernel module for 3.19.0-15 and then backed it out, before installing 3.19.0-18… losing MY MIND… and backing it out all together.

down_time

Rarely (EVER) would I suggest not running backups – but in the interest of anything working at all – give R1soft CDP a miss on current Ubuntu Vivid release.

Confirmation came from their technical support as:

Unfortunately, we are currently unable to build hcp module for kernel version 3.19… and 4.0…as we have reported backup failure issue with an I/O error and recently issue has been escalated to development team.

Sad now. Who needs backups anyway (!)?

*Especially when paying for premium products.

One Response to “R1soft support kernel 3.19 to 4.0

  • Article written in June, and update in October

    “The agent installation currently does not support 3.19 or newer kernels for Ubuntu installations. The 3.16 versions should work as intended. Any module for kernels higher then 3.16 will generate I/O errors. ” — R1soft support.

    So four months on – no movement on this. At all. The viabillity of this with Ubuntu or Debian looks bad.

    With 14.04LTS still under support – but a new LTS release out before too long – then they had better have a good plan moving forwards.

    If there was a platform we could move to that was as good – I would be pushing for that.

    r1soft does not support btrfs
    r1soft does not support xfs
    r1soft does not support 3.19 kernel
    r1soft does not support 4.0 kernel

Leave a Reply

Your email address will not be published. Required fields are marked *

%d bloggers like this:
Skip to toolbar