R1Soft Ubuntu Kernel Support

R1soft is an enterprise backup client, CDP no less – Continual Data Protection. It works through an initial block level seed of the devices, and then deltas on top of that. Squishing these down to recovery points periodically. This means the backups are fast, there is no need to scan for changes as you capture them. This is because this is all captured at the kernel (module) level as it commits changes to the file system.

….aye, there’s the rub.

This is great as long as the OS runs a kernel they support.

It used to be the case that they ran a single Ubuntu release behind. So say for example when it was 14.04 out – you could get 13.10 working.

Now, not so much.

At this moment in time it will support neither the 14.10 or the 15.04. So that is the 3.16.x and 3.19.x kernels.

Support will happily link you to modules at this time for 14.10 once they are generated, however 15.04 it is a case of ask really very nicely.

The release cycle is ‘End of May’ for the x.10 release and ‘End of October’ for the x.04 release – once every six months. So at this time their support is ONE YEAR BEHIND.

It is not as if the OS uses bleeding edge kernels, but established ones. Furthermore it is not as if it is unobtainable until release day – as beta’s move to freeze, then release candidates as it approaches the launch window. So for each 6 month release cycle there is a beta or RC in play to test and develop against.

This would not sting quite so much if the product did not cost so much.

To summarise: given that we operate almost entirely CentOS/CloudLinux, Debian/Ubuntu – anyone choosing to upgrade or asking for the most current build of Ubuntu (or the release 6 months old now) will not be able to backed up by our primary bare metal / CDP solution. I would question whether this was the enterprise platform they are suggesting, or that it warrants the premium price tag? Your call.

One Response to “R1Soft Ubuntu Kernel Support

  • An update on this – how silly I am. I *assumed* that the issue was specific to Debian and Ubuntu.

    I had *assumed* that they were concentrating their efforts on the more standard ‘enterprise’ (read stable through using really old stuff and not innovating (okay – except the installed for CentOS7 I like that))… but oh no. CentOS 3.10.0-229.7.2.el7.x86_64 – no dice either. Lush. Is there actually anything current you DO support?

    CentOS7 – either cPanel decided it needed its own kernel – OR – CentOS7 is not supported either as I am directed towards:

    ======================

    You can download it here:
    http://repo.r1soft.com/modules/Centos_7_x64/hcpdriver-cki-3.10.0-229.7.2.el7.x86_64.ko

    — Download the module from the link above and place it here:
    /lib/modules/r1soft
    — Restart the agent:
    # /etc/init.d/cdp-agent start
    — Make sure the module is loaded:
    # lsmod | grep hcpdriver

    ======================

Leave a Reply

Your email address will not be published. Required fields are marked *

%d bloggers like this:
Skip to toolbar